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Installing

Chemoface was developed on the MATLAB environment.
It is a stand-alone application and does not require a MATLAB license installation to run.

Installation on Microsoft Windows(32 or 64 bits): http://www.ufla.br/chemoface/
Downloadand install MCR.EIDownload and install Chemoface

Running
Access the modules from Chemoface home screen (Figure 1).

A screen resolution lower than 1024x768 is not recommended.

Chemoface uses dot (.) as decimal mark.

File Help

Chemoface

Experimental Design

Pattern Recognition

Mubktivariate Calibration

Data Pt Figure 1.Chemoface home screen




Desighing the experiment

* Select the design type (1).
* Select the number of factors (2).

* Select the number of replications for the response (dependent
variable) (3).

* If appropriate, add central point (4) and select the number of
replications (5).

* If Fractional Factorial is used, select the size of the fraction (6).
* If Mixture Design is used, select the Simplex type (7).



» Set the label of the response and the labels and levelsfor the factors (8).

* Note:lf Full, Fractional, Central Composite or Plackett-Burman is used, provide only values for -1
and +1; additional levels (e.g. axial and central points) are automatically calculated.

 If Mixture Design is used, provide values ranging from 0 to 1; constraintscan be used, providing
values>0 and/or <1.

 If Plackett-Burman is used, dummy factors are just left empty. Press Design button (9).

* Note:lt is possible to alternate between coded and uncoded factor levels using menu Edit>
Alternate coded-uncoed variables.

The model will be fitted according to the provided levels (coded or uncoded).

Inserting the responses

Insert the responses (dependent variable) typing it on the table (10) or paste from a spread
sheet using menu File> Paste responses.

Analyzing the design(not applicable toMixture Design)

Select the error type (11) and the confidencelevel (12).

Press Effectsbutton (13) to obtain the effects table (Figure 3A).

Press Pareto’s Chartbutton (14) to obtain a Pareto’s graph for the effects (Figure 3B).




File Edit Tools

Temp.(°’C) | Time(h) | Str.(RPM) = Veld(%)1 |
1 is 1 100 45
2 35 1 20053
3 35 2 100 54
4 35 2 200 54
5 50 1 10048 10
6 50 1 200 52
7 50 2 100 55
8 50 2 200 57
9 29,8366 1.5000 150 50
10 55.1134 1.5000 150 57
11 425000 0.6591 150 46
12 42,5000 2.3409 150 58
13 425000 1.5000 65.9104
14 425000 15000  234.0896 56
15 425000 1.5000 150 56
16 425000 1.5000 150 55
17 42,5000 1.5000 150 57

— Design Settings
) Label 1 1 Provide only -1 and +1
Design Type: Central Composite ¥ ] e | =) J G1) ‘ levels. Axial points are
Y [Yeld(%) - - * | automatically calculated.
N. of Factors: 3 ~ 2 X1 [Temp.(*C) 35 50
. X2  |Time(h) 1 8 2
N. of Replications: |1 * 3 X3  |Stir.(RPM) 100 200 : -
= -
|
A[V] centralPoints: 3 v 5 E
Fraction Size: |_q ~ 6 X6 L9
X7
Simplex Type: |Lattice -6 points  ~ |7 X8 -
— Experimental Design — Design Analysis

Errorbasedon:‘PureError 11 'J

Confidence level (%): «| 12 | rH 95 |

— Factor Effects
13 Effects | | Pareto’s Chart |14
— Surface

Model: |Quacdratc 15 ~

16| Coefficients

Type:.S-Dsur,.. *19
X .Temp.(... hi 20
y: [Time(h) =

Plot experimental responses 17

Ignore non-significant cosfficients 18

21 Surface

22| Meas xPred




B

Effect _ Error | t

Temp.(*C)(X1) 2 6027 0.5412 4.8092

Time(h)(X2) 6.1773 0.5412 11.4142

Stir.(RPM)(X3) 3.5280 0.5412 6.5189

K1*X2 0.5000 0.7071 0.7071

X1*X3 -0.5000 0.7071 -0.7071

X2*X3 -2.5000 0.7071 -3.5355

p=0.05

Time(h)(X2) i 11.4142-
Stir.(RPM)((3) ! 6.5189 .
Temp.(*C)}X1) i |4.8092 -
X2*)3 3.5355 .
13| lo.70711 §
K12 0. 70711 e

] i 1 1 1 1

0 2 4 G a 10 12

Standardized Effect (absolute value (t))

p significant |
0.0405 yes
0.0076 yes
0.0227 yes
0.5528 no
0.5528 no
0.0715 no

Figure 3. Table and graph for the effects




Building model and response surfaces(not applicable
to Fractional and Plackett-Burman designs)

e Select the model type (15).

* Press Coefficients button(16) to obtain a table with the model coefficients
(Figure 4A).

* Choose if experimental responses should be plotted (17) and if only significant
coefficients (18) should be used for model fit.

 Select the graph type (19).

e For design with more than two factors, select the factors to be plotted (20)
and set the level of the no plotted factor(s)(Figure 4B).

* Press Surface Plot button (21) to obtain the graph and the statistics for the
model (Figure 4C-D).

* Press Meas. x Pred. button (22) to obtain the graph for measured x predicted
values (Figure 4E)



D A= ) =Je i 14 /ol - 1IN 0. 153 no

Temp.[FCHX1) 1.8404 0.4938 33219 0.0799 no
Tirme{h W2 ) 28.85689 S. 7984 4.9767T 0.0381 yes
Stir. ((RPM M2X3) 0.27T63 0.05a80 4_TE53 0.0413 yes
HA=x2 0.0667T 0.0943 07071 0.5528 no
X1=x3 -5 86667e-04 9 4281e-04 0. 7071 0.5528 no
2W2*H3 =0.0:500 0.0741 -3.5355 0.0715 no
x1= -0.0173 0.0053 -3.2594 0.0826 no
w2= -8.0043 1.1913 -5.0400 0.0372 yes
3= -4 5201e-04 1.1913e-04 -3.8529 0.0612 no

Set value for Stir.(RPM):

150

OK Cancel
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Figure 4.Tables and graph for the model



Additional features

* All obtained tables can be copied using menu Edit> Copy...
* A designed experiment can be saved using menu

* File> Save data.

* Later, this file can be opened using menu File> Open data.

* Experimental assays for a Mixture design can be plotted using menu Tools>
Experimental points.

* Desirability functions can be used to combine multiple responses using
menu Tools> Desirability Function(Figure 5).

* Insert each response set pasting it from a spreadsheet using menu File>
Paste responses. Allocate replications abreast (In example, there are two
replications, (1)).



Desirability fucntion

* Set optimization direction (2), the response name (3), the limit ranges
(4), and the desirability power (5).

* Press Add>>button(6) to compute the desirability values for this
response (7)

* and the global desirability (8).

* To compute a new response set, proceed similarly starting by menu
File> Paste responses. When all response sets were added, copy the
global desirability using Copy Global Desirability button (9).

* The copied desirability can be inserted as responses in the design
table (Experimental Design module) using File> Paste responses



File

— Optimization Direction———  — Limit Range 4 — Desirability Power 5 -
!Larger- { (LTB) v} Lower limt. 0.5 s (below target): | 1
Target value: | 0.96558 el 1 | 9
[W Density | Upper limt: | 13 (above targe 1 | Copy Giobal Desirability
— Original Responses — Individual Desirabilties — Global Desirability
1 2 H1 pH2 Densit D1 D2
1 0.5000 0.5500 1 0 0.1333 - 1 0 0.0913
2 0.6120 0.6730 2 0.7000 1 0.9333 0 2 0.3130 8 0.4493
3 0.8820 1.0800 3 0.5000 0.4333 0 3 0.5489 0.5605
4 1.1450 1.2600 6 4 0 0.0333 0 4 0 0.1780
5 0.8760 0.9640 5 0.2333 0.2000 0 5 0.3312 0.3406
6 0.6730 0.7400 Add >> 6 0 0.1000 0= 6 0 0.1732
7 0.7810 0.8590 7 0.0667 0.0333 0 7 0.1530 0.1223
8 0.9980 0.9960 8 0.4333 0.5333 0 8 0.5194 0.5750
9 1.0920 1.1000 9 0.1000 0.1667 0 9 0.2720 0.3536
10 1.1980 1.1960 10 1 0.9000 0 10 0.9341 0.8849
11 1.2000 1.3000 11 0.9333 0.9667 0~ 11 0.9037 0.9832
12 1.1990 1.2000 < » 12 0.8533 0.8539

Figure 5. Desirability function




Pattern Recognition

File Edit
— Data
Pretreatment r
F ~ > Mesan center
2 Mean center -~ i H
Variables 15
255 295 [ 300 ] 301 303 305 \ 313
spring 21.4762 8. 9048 0.4286 -4.6190 27619 3 -2.8571 ~
spring -25.4762 3.9048 05714 -3.6190 -1.2381 -3 -3.8571|
spring -22.4762 4, 39048 -0.5714 -6.6190 -1.2381 -3 -2.8571|=
Sampies spring -15.4762 59048 05714 -£5.6190 0.7619 o 28571 —
spring -15.4762 3.9048 0.4286 -2.6190 -0.2381 17 -1.8571
spring -9.4762 -0.0952 -1.5714 2.3810 -1.2381 4 2.1428
spring -22.4762 s 9048 0.4286 -2.6190 -0.2381 o -1.8571
summer 32.5238 -0.0952 1.4286 3.3810 -1.2381 2 3.1429 _
15[T] . | - ———— rfo:’l'\r—\ ﬂiﬁmil e - e - a A .;vs
— Principal Component Analysis ~— Hierarguical Cluster Analysis-
17 | Copy table data — Dista Type
[ Run PCA ] a : [ ] nes S
PC=# Variance(?:) Cumulative variance(%s) 11 Euchdean vJ
— PCA plots 1 64.4583 64 4583
6| | Colored by sample classes 2 20.9123 85.3706 — Linkage Type =
3 43428 897134 12 Furthest |
Plottype: | points 8 -~ | 7| Scores Piot | 4 36973 93.4107
= . s 2.177s 9s. 5882 A
sx‘-"’"s: PC1 = 8['—°“""9°P'°'] 6 1.2997 96.8879 13[ | Apply PCA to data
e B 10[ Biplot ] 7 0.9284 97.8163
= s 0.7494 938 5658
Z axis: none 16/ Copy piot data | 9 0.6868 99 2526 14 [_Dendrogram.]
10 0.2709 99 5235

Figure 6. Pattern recognition by PCA and HCA



Inserting data set

* Type data on the table (1) or paste it from a spreadsheet (or from Data
Organization module)usingmenu File> Paste data. Only numeric data
should be inserted. Use sample in rows and variables in columns.

* If appropriate, insert sample labels using menu Edit> Sample labels or
classes. If there are sample classes, it can be inserted similarly (Figure
7A).

* If appropriated, insert variable labels using menu Edit> Variable labels. If
dataset is from continuous variables, use > Continuous variables (Figure
7C) and insert the range. If dataset is from discrete variables, use >
Generic variables(Figure 7B).

* Note: if labels are not provided, these are numbered.!!!



Insert sample labels by using ; delimiter
g;SPring;Spring;summer;Summer; Summ:

0K || Cancel

Insert variable labels by using ; delimiter
1313;315;329,;339;353,363,405,435,515

OK || Cancel

Insert sample labels by using ; delimiter
abcdefgabcdefgabcdefy |

D

Figure 7. Inserting sample and variable labels



Data pretreatment

* Select the pretreatment method (2).
* Press Applybutton (3).

* Note:Multiple pretreatment methods can be applied just by

selecting the mand pressing Apply. To return to the original

data after a pretreatment, select “No preprocess” and press

Apply



Performing PCA

* Press Run PCA button (4).

 Select PC to be plotted on X and Y axis (5). If a 2D plot is used, select PC to
be plotted on X and Yaxis and set Z axis in “none”. However, for a 3D plot
(Figure 8D), select the PC to be plotted on all 3 axis: X, Y and Z.

* Note: If sample classes are provided, they may be colored on the
scores plot: select “Colored by sample classes”(6).

* Optionally sample labels also can be inserted: just provide the labels
when solicited (Figure 7D).

* For scores graph, press Scores plot button (7)(Figure 8A).
* For loadings graph (Figure 8B), select the plot type: points or vectors (8).
* Press Loadings plot button (9)



= For a scores and loadings graph (Figure 8C), press Biplot button {10)
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Performing HCA

* Select the distance type (11).
 Select the linkage type (12).
* Note:Optionally PCA can be preciously applied to HCA:

* select Apply PCA to data (13) and select the number of PC to be used
when solicited.

* Press Dendrogram button (14) to run HCA and obtain the dendrogram
(Figure 9B).

* Insert the threshold to color the similar groups (Figure 9A). ,
* If it is not applicable, press Cancel.



Set the threshold to color the groups in dendrogram;
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Figure 9. HCA plot




Figure handling

 Saving figure with high resolution

e Access menu File> Export set up at the figure window.

e At the setup window (Figure 18A), access Rendering (1).
 Set the color to be saved, e.g., RGB color, gray scale, etc (2).
 Set the resolution to be saved, e.g., 600 dpi (3).

* Press Export button (4).

 Set the file name (5) (Figure 18B)

 Select the file type, e.g., .tif (6).EPress Savebutton(7)

* Note: If .fig (MATLAB figure) is selected in file type, the file can be opened
only by using menu File > Open Figure in the Chemoface home screen or by
Matlab software. Figures(.fig) can be edited (e.g., font size, font color) only
on the Matlab software.



rI ~ Properties

Apply to Figure

Restore Figure

a

Export...

O

[
I
|
|
[
[

]
I
J
|
|
]

SiIEL—| Colorspace: 2| RGB color - |
1 %ﬂ [#] Custom color: | w |
Lines [] Custom renderer: | painters {vector format) | « |
Resolution (dpi): | B0L -3
Keep axis limits
Show uicontrols
.'I
~ Export Styles
Load settings from: [ default -]
Save as style named: I_l:I!Faul'l: | [ Save ]
Delete a style: [ »=| | Delete
A

A Bitmap fle (".bmp)
EPS filz (*eps)

JPEG images ("ipg)

Erhanced metafile (*.emf)

FPairtbrush 24-bit file (*.pox)

Fortable Bimap fila {~pbm)

Portable Documert Format (*.pdf)
Fortable Graymap fia [ pgm)
Fortable MNetwork Graphica fils (" prig)

Fortable F'i::maE il Eiﬁi
B TIFF no compression mmage (L)

S Jows fig ~] | 7 save
6 | MATLAB Fgure (~ fig) | Cancel
IMATLAB Fgure (- fig) _II <

Figure 18. Exporting figure




Tools on the figure window

Save figure Print 7., HReaddata Enable/disable

{low resolution)  figure Click over graph
io read values Legend*

Fi.,\_l/ 7 7

DEde |RXODR|0E

Move  Rolate 3D Enable/disable
graph  graph color bar

*To move legend, click with left mouse button and drag.




