LECTURE 4



Creating complex formulas

* Excel is a spreadsheet application that can help you

. : K v x| =B4*SBS1
calculate and analyze numerical information for

household budgets, company finances, inventory, I E:::.n55] <
and more. To do this, you need to
understand complex formulas. Price Sales Tax

* In this lesson, you'll learn how to write complex Eth I éi'gg:' :54*2?5315.!
formulas in Excel following the order of operations. $g:gg $n:55
You will also learn about relative and absolute cell zer $49.99 $2.75
references, as well as how to copy and fill $8.25 $0.45

formulas containing cell references.



The order of operations

* Excel calculates formulas based on the following order of operations:
* Operations enclosed in parentheses

* Exponential calculations (to the power of)

* Multiplication and division, whichever comes first

* Addition and subtraction, whichever comes first



Examples

Example 1

formula becomes

The following example demonstrates how to use the 4

order of operations to calculate a formula:

formula becomes

40/(10-8)*412

\

A2

\

Perform the operation in

parentheses first: 10-8=2

Next calculate the exponent: 4*2=16

Example 2 4W :,. sﬁo* c”cin'es QEfO—e-.T”;gia:L%n
First, Excel will calculate the amount sold in el e
parentheses: (19%¥1.99)=37.81 White Pete Lily seeds “a " | "o
and(33*1.99)=65.67 Total Pete Lily seeds. The fina arswer is 320
Second, it will divide the White Pete Lily seeds .

. eed Inventory Packets Sold |Price Percent of Total Sold
amount by the Total Pete Lily seeds Pete Lily - Blue 1] s199 1222
amount:37.81/65.67=.5758. AR I RE 1.99)(33*1.99)§100

Last, it will multiply the result by 100 to obtain the
value as a percent: .5758*100=57.58.




To create a complex formula using the order of

operations

Click the cell where you want the formula result to appear
(F11, for example).

Type the equals sign (=).

Type an open parenthesis, then click the cell that contains
the first value you want in the formula (F4, for example).

Type the first mathematical operator (the addition sign,
for example).

Click the cell that contains the second value you want in
the formula (F5, for example), then type a closed
parenthesis.

Type the next mathematical operator (the multiplication
sign, for example).

Type the next value in the formula (0.055 for 5.5% tax, for
example).

Click Enter to calculate your formula. The results show
that $2.12 is the tax for the nursery order.

o =] Em Ln s La | pa

10
1
12
13

SUM v (" KV [e| =[Fa+F5)*0.055

B &

D

,l(@?) Eo/omim} E’B @Eﬁa @Cmm&

ITEM ITEM #
LE Tomato Planter Bags 5G324
M - Cord AU396

Price

$18.99
50.12

Quantity
2

5

Total

$37.98

50.60

Tax

|<(ra+ £5)0.055

Total

$40.70




Working with cell references

* In order to maintain accurate formulas, it is necessary to understand
how cell references respond when you copy or fill them to new cells
in the worksheet.

* Excel will interpret cell references as either relative or absolute. By
default, cell references are relative references. When copied or filled,
they change based on the relative position of rows and columns. If
you copy a formula (=A1+B1) into row 2, the formula will change to
become (=A2+B2).

* Absolute references, on the other hand, do not change when they
are copied or filled and are used when you want the values to stay the
same.



Relative references

 Relative references can save you time when you're repeating the
same type of calculation across multiple rows or columns.

* In the following example, we're creating a formula with cell
references in row 4 to calculate the total cost of the electric bill and
water bill for each month (B4=B2+B3). For the upcoming months, we
want to use the same formula with relative references (C2+C3,
D2+D3, E2+E3, etc.). For convenience, we can copy the formula in B4
into the rest of row 4, and Excel will calculate the value of the bills for
these months using relative references.



To create and copy a formula using relative
references

Select the first cell where you want to enter the formula (B4,
for example).

Enter the formula to calculate the value you want (B2+B3, I
for example). A B C
Press Enter. 1 JAN FEB
Select the cell you want to copy (B4, for example), then click|'| 2 Electric $ 116.45 | 5 125.15
the Copy command from the Home tab.

3 Water S 50.15 | S 48.75
Select the cells where you want to paste the formula, then
click the Paste command from the Home tab. You can also A Total ‘ =E1+EE| l

drag the fill handle to fill cells I
The formula will be calculated.

Your formula is copied to the selected cells as a relative
reference (C4=C2+C3, D4=D2+D3, E4=E2+E3, etc.), and the
values are calculated.



Absolute references

* There may be times when you do not want a cell
reference to change when copying or filling cells. You can
use anabsolute reference to keep a row and/or column
constant in the formula.

SASZ: The column and the row do not change when copied.

e An absolute reference is designated in the formula by
the addition of a dollar sign ($). It can precede the
column reference, the row reference, or both. SA2

AS2: The row does not change when copied.

The column does not change when copied.

* In the below example, we want to calculate the sales tax
for a list of products with varying prices. We'll use an
absolute reference for the sales tax (SBS1) because we
do not want it to change as we are copying the formula
down the column of varying prices.



To create and copy a formula using an absolute
reference

1. Select the first cell where you want to enter the formula (C4, for example).

2. Type an equals sign, and then click the cell that contains the first value you
want in the formula (B4, for example).

3. Type the first mathematical operator (the multiplication sign, for example).

4. Type the dollar sign (S]), then enter the column letter of the cell you are
making an absolute reference to (B, for example).

5. Type the dollar sign (St)' then enter the row number of the same cell you are
making an absolute reference to (1, for example).

6. Press Enter to calculate the formula.

7. Select the cell you want to copy (C4, for example), then click
the Copy command from the Home tab.

8. Select the cells where you want to paste the formula, then click
thﬁ Paste command from the Home tab. You can also drag the fill handle to fill
cells.



Working with basic functions

* Figuring out formulas for calculations you want to make in Excel can
be tedious and complicated. Fortunately, Excel has an entire library
of functions—or predefined formulas—you can take advantage of.
You may be familiar with common functions
like sum, average, product, and count, but there are hundreds of
functions in Excel, even for things like formatting text, referencing
cells, calculating financial rates, and analyzing statistics.

* In this lesson, you'll learn the basics of inserting common functions
into your worksheet by utilizing the AutoSum and Insert
Functions commands. You will also become familiar with how
to search and find various functions, including exploring
Excel's Functions Library.



Basic functions

A function is a predefined formula that performs
calculations using specific values in a particular order. One
of the key benefits of functions is that they can save you
time because you do not have to write the formula
yourself. Excel has hundreds of functions to assist with
your calculations.



The parts of a function

* The order in which you insert a function
is important. Each function has a specific
order—called syntax—which must be
followed in order for the function to
work correctly. The basic syntax to create
a formula with a function is to insert
an equals sign (=), function name (SUM,
for example, is the function name for
addition), and argument. Arguments
contain the information you want the
formula to calculate, such as a range of
cell references.

=SUM(B3:B12)

—————




Working with arguments

Arguments must be enclosed in parentheses. Individual values or cell
references inside the parentheses are separated by either colons or commas.

* Colons create a reference to a range of cells.

For example, =AVERAGE(E19:E23) would calculate the average of the cell
range E19 through E23.

 Commas separate individual values, cell references, and cell ranges in
parentheses. If there is more than one argument, you must separate each
argument by a comma.

For example, =COUNT(C6:C14,C19:C23,C28) will count all the cells in the
three arguments that are included in parentheses.



To create a basic function in Excel

$12.20  $61.00 3-Aug 11-Aug
$7.33 $36.65 3-Aug 11-Aug
SeIeCt the Ce” Where the answer =%ﬁb|ﬁclcls all the numbers in a range of cells
Wi” appear (F15’ for example)' Unit Price i:ﬁmiis Ordered Date Received
. $12.03 :;ﬁf:gﬂ:ggﬂmm 18-Sep 26-Sep
Type the equals sign (=), then $1595 | o awnams | 18-Sep 26-5ep
o $5.87 | (&) sumxzey2 8-Au 14-Au
enter the function name (SUM, 583 |G | savy  14ug
for example) $13.54  $27.08 22-Jul 29-Jul
] Unit Price  Subtotal Date Ordered Date Received
$5.86 558.60 12-Sep 17-Sep
Enter the Ce”S .for. 540.26 $80.52 12-5ep 17-5ep
the argument inside the ) S0 e e
pa rentheses. $3.20]  $48.00 6-Sep 12-Sep
$3.40 $17.00 6-Sep 12-Sep
1 54,10 $32.80 b-5Se 12-5e
Press Enter, and the result will e e e o
a p pea r. 57.33 $36.65 8-Aug 11-Aug

|=sum(Fe:F1a)



The Function Library

x| = 9 - - Book2 - Microsoft Excel
. g Game Insert Page Layout Formulas Re
* A great place to explore functions | s = @ 8 @ 2 @ 1 @ m

is in the Function Library on the
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Function * U d . T[me Reference‘uT g Fu t
-

Formulas tab. Here, you can search - TS T T o T T T
and select Excel functions based on
categories such

as Financial, Logical, Text,

and Date & Time. Click the buttons
in the interactive below to learn
more.
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To insert a function from the Function Library

Select the cell where the answer will appear (16, for
example).

Click the Formulas tab.

From the Function Library group, select the function
_<I:_§tegory you want. In this example, we'll choose Date &
ime.

Select the desired function from the Date & Time drop-
down menu. We'll choose the NETWORKDAYSfunction to
count the days between the order date and receive date
in our worksheet.

The Function Arguments dialog box will appear. Insert
the cursor in the first field, then enter or select the cell(s)
you want (G6, for example).

Insert the cursor in the next field, then enter or select the

cell(s) you want (H6, for examplef.

1tity Type Unit Price  Subtotal _Date Oird

ad_Date Received Delivery Time
' 17-Sep|KDAYS(G6)
ol

10 boxes 55.86
2 cartons $40.26 17-Sep
= — ~ | u
Function Arguments . @ J
MNETWORKDAYS
Start_date | g6 (| = 40433
End_date |E| =
Helidays |E| =
Returns the number of whole workdays between two dates.
Start_date iz 3 serial date number that represents the start date.
1t*l
Formul ult =
! ok || cancal

tity Type Unit Price  Subtotal Date Ordered_Date Received Delivery Ti
10 boxes $5.86 $58.60 12-Seq! y
2 cartons $40.26 580.52 12-Sep

Function Arguments

MNETWORKDAYS
Start_date |G&
End_date |Hg|
Holidays

Returns the number of whole workdays between two dates.

End_date isa

serial date number tiat represents the end date.

i

[ oK ] | Cancel




Using the Insert Function command

Select the cell where the answer will appear (A27, for
example).

Click the Formulas tab, then select the Insert
Function command.

The Insert Function dialog box will appear.

Type a description of the function you are searching for,
then click Go (Count cells with text, for example). You
can also search by selecting a category.

Review the results to find the function you want
(COUNTA, for example). Click OK.

The Function Arguments dialog box will appear. Insert
the cursor in the first field, then enter or select the
cell(s) you want (A6:A14, for example).

Insert the cursor in the next field, then enter or select
the cell(s) you want (A19:A23, for example). You can
continue to add additional arguments if needed.

|  Counts the number of cells in a range that are not empty.

Insert Function l 7 ﬂhl

Search for a function:
Count cells with Text G0

Or select a category: | Recommended IEI

Select a function:

.
COUNT Review the recommended -
COUNTIF results and select a function
DCOUNT .

COUNTBLANK en click OK

TEXT
DCOUNTA

_‘-

COUNTA(valuel,value?,..)

Help on this function | ik %J | Cancel
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To view the Print pane

Click the File tab.
This takes you
to Backstage view.

Select Print.

The Print

pane appears, with
the print

settings on the left
and Print

Preview on the
right.
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To print the entire workbook:

Click the File tab. r
Select Print to access the Print

Print Active Sheets
Only print the active sheets

Print Active Sheets

pane- - Only print the active sheets
Select Print Entire Print Entire Workbook
WorkbOOk from the print ) Print the entire workbook I}
range drop_down menu. i grrir:]:;ﬁl:ﬂiﬁ:current selection

Click the Print button.

Ignore Print Area



To print a selection or set the print area

* Select the cells you want to print.

* Click the File tab.

e Select Print to access the Print
pane.

e Select Print Selection from

the print range drop-down menu.

* You can see what your selection
will look like on the page in Print
Preview.

e Click the Print button.

(xR (s T, O T T

il B C
Allenson, Carol 5 5,897.00 || 5 2,356.00
Altman, Zoey 5 666.00 || 5 6,210.00
Aurelio, Fies S 5,889.00 || 5 9,385.00
Aurelio, Vig $ 876500 %  9,258.00
Bergman, Jeffery $  1,928.00 %  6,595.00
Bittiman, William S 4,108.00 | § F.172.00
Carlson, David S 6,302.00 | S 358.00
Carlton, Potter S 3,647.00 | S 2,858.00




To fit a worksheet on one page

Click the File tab.

Select Print to access the Print
pane.

Select Fit Sheet on One Page from
the scaling drop-down menu.

Your worksheet is reduced in size
until it fits on one page. Remember
that if it is scaled too small, it might
be difficult to read.

i

*  Fit Sheet on One Page
# Shrink the printout so that 1...

-

_EI Mo Scaling

|1_ Print sheets at their actual
_[100) cize

7 Fit Sheet on One Page
%__ | Shrink the printout so that it
L) fits on one page [%

Fit All Columns on One Page
3 Shrink the printout so that it
I5 one page wide

kS Fit All Rows on One Page
™ Shrink the printout so that it
@ is one page high

Custom Scaling Options...

i



To modify margins while in Print Preview

Click the File tab.
Select Print to access the Print pane.

Click the Show Margins button. Your
margins will appear.

Hover your mouse over one of the margin
markers until the double arrow appears.

Click and drag the margin to your desired
location.

Release the mouse. The margin is modified.



To use print titles

Click the Page Layout tab.
Select the Print Titles command.

The Page Setup dialog box appears. Click the icon at
the end of the Rows to repeat at top field.

Your mouse becomes the small selection arrow .
Click the rows you want to appear on each printed

page. The Rows to repeat at top dialog box will i : :
record your selection.

Click the icon at the end of the Rows to repeat at | 2 & fendy L0015 33810015 4BM0JS 4[5 g0
top field. 3 Aurelio, Fiel Page Setup - Rows to repeat at fop: ) |5

. 4 Aurelio, Vig
Repeat for Columns to repeat at left, if necessary.|. =,

‘51:51

Click OK. You can go to Print Preview to see how
each page will look when printed.



